Connectivity issues

March 27, Tue
Affected Service: Server Boxberg 01
  • Identified
    We're currently having big network problems with our server in Boxberg, Germany.
    You may experience slower load times but everything should continue working well.
    We can't do anything against that problem but we hope that everything will recover soon.

    13:32, Mar 26 UTC
  • Resolved
    The network seems to have stabilized.
    We don't expect any further outages because of that.

    11:45, Mar 27 UTC
Back to current status